barbitoff programmer`s blog

Здесь я публикую заметки из программерской жизни: грабли, на которые мне случилось наступить, проблемы, для которых было найдено элегантное (или не очень) решение, а также все, с чем мне пришлось столкнуться и чем хотелось бы поделиться =)
PS Если хотите меня поблагодарить - на странице есть 3 места, чтобы это сделать =)

четверг, 3 декабря 2015 г.

Spring Tools Suite: ошибка "You need to run build with JDK or have tools.jar on the classpath..." при просмотре pom-ки

Проблема

При открытии в Spring Tools Suite pom-ки проекта вверху отображается ошибка:
You need to run build with JDK or have tools.jar on the classpath...
Причина

STS запущен из-под java из jre, а не JDK.

Решение

Поправить PATH системы таким образом, чтобы java бралась из JDK, а не из JRE. 

Комментариев нет:

Отправить комментарий